More high end SandyBridge goodness, the ASUS P8Z68-V Pro

Subject: Motherboards | May 16, 2011 - 05:00 PM |
Tagged: asus, z68, sandybridge

The expiration of the NDA on the Z68 chipset has launched an impressive amount of reviews, which represents just how much choice you will have if you upgrade to a high end SandyBridge motherboard.  That is also easy to see if you search NewEgg for Z68 based boards, which range from $120ish to over $350 depending on the features.  One possibility is the ASUS P8Z68-V Pro, a middle of the road $210 board sporting two PCIe x16 slots running 8x is you use dual GPUs along with an impressive array of output and input ports and 7.1 sound.  Legit Reviews didn't hand it an Editors Choice Award for nothing, this board has a lot going for it.

View Full Size

"Prior to the Intel Z68 chipset, you would have to choose. Either you could have integrated graphics and no overclocking capabilities, or overclocking abilities as well as the need to invest in a discrete graphics card. Fortunately that is no longer the case. We now have the best of both worlds at our fingertips with motherboards like the ASUS P8Z68-V Pro that we have been looking at today. Every gaming benchmark that we ran, the ASUS P8Z68-V Pro was able to out perform the GIGABYTE P67A-UD7..."

Here are some more Motherboard articles from around the web:



May 21, 2011 | 09:11 PM - Posted by Bernie (not verified)

Great board, but I have yet to be able to get the 'Standby/Sleep' function going. Is there a trick that I'm missing?

I've tried updating to the latest BIOS update and I've reinstalled Windows7 Ultimate (x64). Nothing seems to work. It will go into Standby, but when I wake it up, the video and USB ports are dead. If I force a re-boot, it will act as though I'm coming out of standby.

Help! Please!!


June 12, 2011 | 02:49 PM - Posted by Stefan (not verified)

I've got the same issue.
All ASUS drivers installed.
Tried with all custom software and with none. Still doesn't work.

June 14, 2011 | 12:51 PM - Posted by Stefan (not verified)

Try setting your Internal PLL Overvolage to "Disabled" rather than leaving it at AUTO, and see if that helps.

It did for me =)

June 23, 2011 | 01:17 AM - Posted by FTA Electronics Ent (not verified)

Make sure to power off the micro switches in the right upper corner of the board. A specialy the one that does overclocking control.

Post new comment

The content of this field is kept private and will not be shown publicly.
  • Lines and paragraphs break automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <blockquote><p><br>
  • Web page addresses and e-mail addresses turn into links automatically.

More information about formatting options

By submitting this form, you accept the Mollom privacy policy.