Update: Upcoming Catalyst 9.3 last to support R500 and below

Subject: Graphics Cards | March 5, 2009 - 12:00 AM |
Tagged:

I just found out with the upcoming release of the Catalyst 9.3 driver (sometime in mid-March), ATI will officially stop supporting Radeon cards based on the R500 architecture and earlier with the monthly driver releases.  Instead, those older GPUs will be supported on a quarterly driver release schedule.  (Note: Catalyst 9.3 will support ALL Radeon GPUs - 9.4 and beyond will implement "legacy status" on the aforementioned cards.)

http://www.prime-news.info/wp-content/ati-catalyst-logo.jpg

I imagine there will be some negative feedback from this, but in reality, it kind of makes sense.  ATI will be able to dramatically lower the size of the driver downloads and quite frankly the team isn't spending much time on bug fixes or performance enhancements for that level of GPU.  To translate from architecture codenames to actual card names, the GPUs that will no longer be included in the monthly Catalyst release X1900 and below.  If we put it in context, that the X1900 was officially released in January of 2006, we can guesstimate that very few users that are regularly looking for driver updates are still utlizing that hardware.  And if some are, then the quarterly driver releases will still likely be enough to satisfy.

As for ATI's reasoning for this move, much of it likely has to do with reorganizing resources for properly support the upcoming transistion to Windows 7 drivers. 

I have AMD's official response to the news below for those of you looking for a complete list of the GPUs being relegated to the "legacy support" status. 

The upcoming release of ATI Catalyst 9.3 will be the last driver to provide a monthly driver update for graphics products predating the R6xx series.  What that means is all R300, R400 and R500 series products will be moved to legacy support status  - meaning they will be removed from the core Catalyst update and QA testing will be reduced.  Moving forward, these products will receive critical fixes if needed as well as updates on a quarterly schedule rather than the monthly schedule adhered to for current products.

 

Legacy support status is typically reserved for non-current products that have reached a point at which existing drivers optimize performance of the graphics product in question and further driver updates will yield little to no performance improvement.  We continue to support non-current products well after drivers have reached this optimal state in order to ensure support for new applications and games.

 

By moving pre6xx products to legacy support status, we will be able to focus more of our software engineering resources on current and future products, operating systems and applications.   

 

The following is a complete list of products moving to legacy support status:

       ATI Radeon 9500 Series

       ATI Radeon 9550 Series

       ATI Radeon 9600 Series

       ATI Radeon 9700 Series

       ATI Radeon 9800 Series

       ATI Radeon X300 Series

       ATI Radeon X550 Series

       ATI Radeon X600 Series

       ATI Radeon X700 Series

       ATI Radeon X800 Series

       ATI Radeon X850 Series

       ATI Radeon X1050 Series

       ATI Radeon X1300 Series

       ATI Radeon X1550 Series

       ATI Radeon X1600 Series

       ATI Radeon X1650 Series

       ATI Radeon X1800 Series

       ATI Radeon X1900 Series

       ATI Radeon Xpress Series

       ATI Radeon X1200

       ATI Radeon X1250

       ATI Radeon X2100 Series

       ATI FireGL X1-128

       ATI FireGL X1-256

       ATI FireGL X2-256

       ATI FireGL X2-256t

       ATI FireGL X3-256

       ATI FireGL Z1

       ATI FireGL V3100

       ATI FireGL V3200

       ATI FireGL V3250

       ATI FireGL V3300

       ATI FireGL V3350

       ATI FireGL V3400

       ATI FireGL V5000

       ATI FireGL V5100

       ATI FireGL V5200

       ATI FireGL V7100

       ATI FireGL V7200

       ATI FireGL V7300

       ATI FireGL V7350

       ATI FireMV 2200

       ATI FireMV 2250

No comments posted yet.

Post new comment

The content of this field is kept private and will not be shown publicly.
  • Lines and paragraphs break automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <blockquote><p><br>
  • Web page addresses and e-mail addresses turn into links automatically.

More information about formatting options

By submitting this form, you accept the Mollom privacy policy.